Problem updating from Drupal Core 8.3.7 to 8.4.0 with composer

by user79831   Last Updated October 12, 2017 23:07 PM

I am having trouble updating from Drupal 8.3.7

when running "composer why-not drupal/core 8.4.0" i get the following results:

drupal/core 8.4.0 requires symfony/class-loader (~3.2.8) andeersg/bouvet-d8-project dev-Stinis does not require symfony/class-loader (but v2.8.28 is installed) drupal/core 8.4.0 requires symfony/console (~3.2.8) andeersg/bouvet-d8-project dev-Stinis does not require symfony/console (but v2.8.28 is installed) drupal/core 8.4.0 requires symfony/dependency-injection (~3.2.8) andeersg/bouvet-d8-project dev-Stinis does not require symfony/dependency-injection (but v2.8.28 is installed) drupal/core 8.4.0 requires symfony/event-dispatcher (~3.2.8) andeersg/bouvet-d8-project dev-Stinis does not require symfony/event-dispatcher (but v2.8.28 is installed) drupal/core 8.4.0 requires symfony/http-foundation (~3.2.8) andeersg/bouvet-d8-project dev-Stinis does not require symfony/http-foundation (but v2.8.28 is installed) drupal/core 8.4.0 requires symfony/http-kernel (~3.2.8) andeersg/bouvet-d8-project dev-Stinis does not require symfony/http-kernel (but v2.8.28 is installed) drupal/core 8.4.0 requires symfony/process (~3.2.8) andeersg/bouvet-d8-project dev-Stinis does not require symfony/process (but v2.8.28 is installed) drupal/core 8.4.0 requires symfony/routing (~3.2.8) andeersg/bouvet-d8-project dev-Stinis does not require symfony/routing (but v2.8.28 is installed) drupal/core 8.4.0 requires symfony/serializer (~3.2.8) andeersg/bouvet-d8-project dev-Stinis does not require symfony/serializer (but v2.8.28 is installed) drupal/core 8.4.0 requires symfony/translation (~3.2.8) andeersg/bouvet-d8-project dev-Stinis does not require symfony/translation (but v2.8.28 is installed) drupal/core 8.4.0 requires symfony/validator (~3.2.8) andeersg/bouvet-d8-project dev-Stinis does not require symfony/validator (but v2.8.28 is installed) drupal/core 8.4.0 requires symfony/yaml (~3.2.8) andeersg/bouvet-d8-project dev-Stinis does not require symfony/yaml (but v2.8.28 is installed)

Trying to update one of the mentioned packages just result in composer telling me i cant because Drupal 8.3.7 needs a lower version. So i cant update the packages and i cant update Drupal, am i stuck in a catch22?

Does anybody know what the problem might be? When i run composer update drupal/core --with-dependencies it says that everything is up to date even though it is still at 8.3.7.



Related Questions


Updating core from 8.2 to 8.3 via composer

Updated April 18, 2017 14:07 PM