Drush does not acknowledge release of new core update

by Ibn Saeed   Last Updated July 08, 2017 00:07 AM

I am trying to update my drupal 7.31 core to 7.32 via Drush.

I ran the following commands

$ drush pm-releases

Project  Release  Date         Status                           
drupal   7.x-dev  2014-Oct-15  Development                      
drupal   7.32     2014-Oct-15  Supported, Recommended, Security 
drupal   7.31     2014-Aug-06  Security      

After the above command i ran the following:

$ drush pm-update drupal

Update information last refreshed: Thu, 10/16/2014 - 07:33
 Name    Installed Version  Proposed version  Message 
 Drupal  7.31               7.31              Unknown 


No code updates available. 

so i ran the following command:

$ drush pm-update drupal-7.32

Update information last refreshed: Thu, 10/16/2014 - 07:33
 Name         Installed Version  Proposed version  Message                     
 drupal-7.32  Unknown            Unknown           Specified version not found 


No code updates available.   

Here are the versions for drush and composer. Both are to the latest versions.

$ drush version

 Drush Version   :  7.0-dev 

Composer version 1.0-dev

Tags : drush updating


Answers 6


drush rf will refresh the available releases and at that point you should be able to run drush up or drush up drupal.

Laryn - CEDC.org
Laryn - CEDC.org
October 16, 2014 04:01 AM

The solution offered by Danny Englander worked.

Restarting mysql server did the trick.

Thanks Danny.

Ibn Saeed
Ibn Saeed
October 16, 2014 04:49 AM

I have the same problem. Can't get to update list of modules and core. Tried CC, cache_update truncate. Well everything I could come up with and still nothing. What is strange is that on localhost is where I get this, on remote server it is ok.

So I fixed it somehow with disabling and uninstaling update manager and installing it again.

Marko Blazekovic
Marko Blazekovic
January 24, 2015 23:14 PM

I also had the same problem.

Restarting MySQL server didn't work for me.

Disabling update manager, uninstalling it and then re-enabling it worked for me.

$ drush -y dis update
$ drush -y pm-uninstall update
$ drush -y en update
pachabhaiya
pachabhaiya
March 02, 2015 15:56 PM

First of all execute:

drush pm-releases drupal

Then you should see all tag names like this:

 Project  Release  Date         Status                                      
  drupal   7.38     2015-Jun-17  Supported, Recommended, Security, Installed 
  drupal   7.x-dev  2015-Jun-17  Development

Now you can get Project name and Release number like this 'drupal-7.38' and execute this to force update to that release:

drush dl drupal-7.38

You can even choose a development version of update by write the development release number.

This also work with update modules. If you need to force update for a module like ctools for a dev release you can execute:

drush dl ctools-7.x-1.x-dev

Enjoy drush <3

Saud AlFadhli
Saud AlFadhli
June 27, 2015 22:05 PM

Using Acquia Dev Desktop and having the same problem trying to update to 7.56. But, NONE of the above options worked.

I typed Drush rf and tried... nope I uninstalled updates module, then tried... nope. I typed drush dl drupal-7.56 and it gives an error saying I cannot download core into a folder with existing core files

Any other suggestions?

I don't see an option to restart Mysql in Acquia dev desktop

turpentyne
turpentyne
July 07, 2017 23:52 PM

Related Questions


drush pm-update status failed

Updated April 19, 2017 16:07 PM



Running drush up to several sites folders at once

Updated September 07, 2016 09:03 AM