Problem with restoring database which has a filestream

by Saeed Hamed   Last Updated April 21, 2017 17:06 PM

When I restored a database backup file, which uses FILESTREAM feature, everything was fine but after a while the database went to the (recovery pending) mode. I tried restarting SQL Server service and it still didn't work. I decided to delete the database and restore it again but I got this error while restoring:

Restore of database 'Ka4' failed. (Microsoft.SqlServer.Management.RelationalEngineTasks)

System.Data.SqlClient.SqlError: FILESTREAM feature is disabled. (Microsoft.SqlServer.SmoExtended)

I've reinstalled SQL Server instance but nothing has changed and it still keeps saying the same error.

According to this page I'm sure that FILESTREAM feature is enabled.

P.S. This is my SQL Server version:

Microsoft SQL Server 2016 (RTM) - 13.0.1601.5 (X64) Apr 29 2016 23:23:58



Related Questions



FileStream Db restore

Updated January 31, 2018 22:06 PM



archiving partitioned filestream table

Updated January 12, 2018 08:06 AM