What to call a API and DB code layer

by Roland   Last Updated November 06, 2017 06:05 AM

In a recent MVVM mobile app project I wrote a set of API classes and Database classes where there was a clear flow of logic between both api and db code. To enforce the way api and db interacted I created an additional abstraction/proxy layer.

For instance the login process was to call this new layer Login function that then:

Call api.Login -->
     on successful login --> 
     clear user table and insert new user details into DB
<-- only then return a successful login

The issue I am having is that I called this layer Database Controller which I do not like as it controls APIs as well as Databases and left me with out a proper name for the actual database controller code.

tl;dr: What do I call a code layer that controls both API and DB controller code?

Related Questions

Method naming: to vs as vs get

Updated April 25, 2018 02:05 AM

Naming conventions for pure functions

Updated August 19, 2018 20:05 PM