How to name type of variable holding axis position in point

by qwdhqwidherfg23   Last Updated October 30, 2017 07:05 AM

There is Point structure for holding x and y co-ordinates for cartesian co-ordinate system.

struct Point
{
  int x;
  int y;
};

I need to name type for holding x and y co-ordinates, instead of int type. The same type for both axis. How can I name this properly?

Edited: PointAxisPosition. Do you think its proper name?

struct Point
{
  PointAxisPosition x;
  PointAxisPosition y;
};
Tags : naming math


Related Questions


Vector API, naming for element-wise multiply

Updated March 28, 2015 06:01 AM




Naming a view class

Updated June 14, 2017 19:05 PM