Best practice on naming an array (i.e. an array of image file names)

by Yahya Uddin   Last Updated September 04, 2017 20:05 PM

I have an array of image file names. e.g:


However, I am confused as to what the best practice of naming this array.

Would it be:

  • imagesFileName: as the array contain multiple images with a file name of each
  • imageFileNames: as the array contain many file names
  • imagesFileNames: as the array contain many images and file names

If this Stack Exchange is not appropriate for questions like this, please tell me which Stack Exchange I should post it on.

Related Questions

Variable naming

Updated November 14, 2017 13:05 PM

How to name variables that clash with functions?

Updated August 21, 2016 08:03 AM