Is wrapping built-in functions with user functions ok?

by Bio Hazard   Last Updated September 03, 2017 03:05 AM

As I was working with a friend on a project I noticed that he created custom functions such as:

function is_empty($val){
  return empty($val);
}
function is_not_empty($val){
  return !empty($val);
}
function is_set($val){
  return isset($val);
}
function is_not_set($val){
  return !isset($val);
}

and is using them instead of the built in functions. I tried talking him out of this practice but he insists that this "naming convention" is to make the code more "understandable".

I would like to know your opinions about the issue, and is this regular behavior or not?

Tags : naming


Related Questions





Naming a view class

Updated June 14, 2017 19:05 PM