enp0s31f6 Cable Unplugged

by Luis Alvarado   Last Updated January 14, 2018 02:02 AM

I followed the following guide looking for a way to solve at last an issue I have been having in 17.10 (Worked in 17.04 but I can't confirm if it did all the time).

The issue can be found in https://ubuntuforums.org/showthread.php?t=2356217 but basically, the Intel ethernet card, suddenly stopped connecting. It simply does not detect an ethernet connection established.

I have physically tried connecting several LAN RJ45 cables to it (Changing between 4 that I know work because they work in other computers at home). I also tried testing it between my computer and an Asus RT5300 and an Asus AC-68U. Currently it is connected directly to a Netgear Orbi (The router) and it does not work (I tried another computer to the same port in the Orbi and it works perfect).

Dmesg mentions the following about the card:

enter image description here

And the Gnome Network GUI shows this:

enter image description here

LSHW shows the following:

enter image description here

ModInfo gave me version 3.2.6-K

enter image description here

Trying to compile the same drivers, following the guide above gave me this (after editing the nvm.c file as mentioned in the guide):

enter image description here

My computer is the following:

enter image description here

The motherboard is the Asus ROG-Maximus VIII Hero Alpha with the latest 3703 firmware update.

I have literally tried a lot of things over the past months with no luck, including the recommendations mentioned here Ethernet adapter was disable on Ubuntu 17.04



Related Questions


Driver r8169 of Realtek

Updated May 27, 2015 00:01 AM

Wifi does not show any wifi networks or wlan0

Updated March 29, 2017 20:02 PM

Ubuntu 14 won't even detect my home wireless network

Updated September 25, 2015 16:01 PM

Wifi password being forgotten

Updated October 03, 2015 04:01 AM

17.10 wireless card no longer found after update

Updated April 28, 2018 10:02 AM