Ubuntu 16.04 driver for Broadcom Limited BCM4350 802.11ac Wireless Network Adapter [14e4:43a3] (rev 08)

by Grant F   Last Updated January 13, 2018 01:02 AM

Tried using this: Installing Broadcom Wireless Drivers, but the [14e4:43a3] (rev 08) isn't listed.

Here's the pertinent output from: sudo lshw -C network

*-network UNCLAIMED     
       description: Network controller
       product: BCM4350 802.11ac Wireless Network Adapter
       vendor: Broadcom Limited
       physical id: 0
       bus info: pci@0000:3a:00.0
       version: 08
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:dc400000-dc407fff memory:dc000000-dc3fffff

I thought it was a kernel issue, but output from: uname -r

4.4.0-109-generic

The wireless was working recently, but between updates I think something happened.

Any thoughts? I tried running through https://help.ubuntu.com/lts/ubuntu-help/net-wireless-troubleshooting.html, but to no avail. Thanks for any help.



Related Questions


Wireless connection keeps dropping out

Updated September 25, 2015 06:01 AM

HP Pavilion tx 1000 Wi-Fi not working

Updated April 24, 2017 00:02 AM

BCM43142 monitor mode : operation not suported!

Updated August 17, 2015 18:00 PM

BCM43228 not working after reboot

Updated September 06, 2015 04:01 AM