How to edit fstab on livecd and change UUID

by Diego Leite   Last Updated May 23, 2020 01:02 AM

I ask for your help to solve this problem on my pc, because I already tried to solve it through several links, but without success!

So, i deleted the boot-efi partition of my Linux Mint 19.3, because the particion also booted Windows 10 that I already uninstalled. Anyway, I have also installed Lubuntu 20.04 LTS and I am using his grub to start Linux mint, however linux mint does not start, analyzing the startup logs, I realize that it does not recognize my Linux partition and gives a "timeout ... UUID .device failed " (something like that). I entered with the Linux mint live cd and found that UUID of the Linux partition is different between "blkid" informations and the bootlog. Searching on net, i saw that I need to change the old UUID of the "fstab" that prevents the recognition of the partition. I started the prompt on livecd and mounted the partition where Linux Mint is installed, "dev / sda2". Then I tried to enter fstab with the command "sudo nano / etc / fstab", but I only had this information below ๐Ÿ‘‡๐Ÿป

"overlay / overlay rw 0 0 tmpfs / tmp tmpfs nosuid, nodev 0 0"

I also tried the commands below๐Ÿ‘‡ but it was the same result!

# mount -o remount, rw / dev / sda1 /

# chmod 666 / etc / fstab

# nano / etc / fstab

I'd like to know how to access my partition's fstab via livecd and, after that, how to replace the old fstab UUID with the new one that appears in the "blkid", because I don't know how to use anything from "fstab" and I think this will solve my problem. I'm a beginner at Linix Mint!



Related Questions


What is PARTUUID in Ubuntu 15.04?

Updated April 19, 2018 23:02 PM

Why are NTFS partition UUIDs shorter than normal?

Updated April 26, 2015 23:00 PM

ALERT ! UUID- does not exist. Dropping to a shell

Updated June 12, 2016 08:00 AM

Ubuntu 18.04 not booting, UUID error

Updated December 18, 2018 20:02 PM