Problem with installing additional drivers for AMD Trinity Radeon Mobility HD7620G

by Andreas   Last Updated June 29, 2018 13:02 PM

Recently I installed Ubuntu 18.04 LTS on my ASUS Notebook U38N (with an AMD Radeon Mobility HD 7620G Graphics card). After the initial installation and the installation of the recommended updates, there was no option shown for additional drivers for the graphics card in the Software & Updates application under the tab "Additional drivers" (only the Broadcom router for the WLAN appears here). Previously, Linux Mint 17 was installed on this notebook. There “fglrx-updates version 2: 15.201.2-ubuntu0.14.04.”1 was installed as a graphics driver - which worked so far very well. Unfortunately, there seems to be no more recent (closed source) drivers from AMD, so I have to work with the open drivers.

The installed kernel version is: 4.15.0-23-generic

I have installed amd64-microcode via Synaptic – and it seems to work well. dmesg | grep microcode

[1.855009] microcode: CPU0: patch_level = 0x06001119

[1.855026] microcode: CPU1: patch_level = 0x06001119

[1.855033] microcode: CPU2: patch_level = 0x06001119

[1.855047] microcode: CPU3: patch_level = 0x06001119

[1.855118] microcode: Microcode Update Driver: v2.2.

After rebooting in nomodeset - “mode”. I have added two repositories

https://launchpad.net/~dokomix/+archive/ubuntu/fglrx-bionic-staging

sudo add-apt-repository ppa:dokomix/fglrx-bionic-staging

sudo apt-get update

https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt-get update

After adding these repositories there have been ca. 22 updates and in the Software & Updates application under the tab "Additional drivers" the option to choose between xserver-xorg and fglrx was shown. The xserver-xorg driver was checkboxed as used. (I tried to choose fglrx but it automatically switches back to xserver-xorg...)

During the reboot, both “normal” and in “nomodeset”, the boot process stopps unfortunately at the start of the User Manager. In the “normal” mode the mouse freezes. In “nomodeset” the boot process simply stopps at starting the User Managar.

Any ideas what I could do to get the (any) graphics driver working. Could it be a bug in the “Software & Updates” application. Are there other repositories with stable builds of xserver-xorg-video-ati…?

Many thanks for your help.



Related Questions


What graphic card do i have? How can I activate it?

Updated November 02, 2018 15:02 PM



How to install AMD graphic drivers on Ubuntu 18.04

Updated August 17, 2018 05:02 AM