How to remove an incorrect package version from Ubuntu

by Mike Slinn   Last Updated October 19, 2015 20:00 PM

An X86 XUbuntu system I work with has Java 8 installed via webupd8, and also a failed version for ARM. I want to remove the partially installed ARM version of Java.

$ sudo apt-cache showpkg oracle-java8-installer 
Package: oracle-java8-installer
Versions: 
8u60+8u60arm-1~webupd8~1 (/var/lib/apt/lists/ppa.launchpad.net_webupd8team_java_ubuntu_dists_vivid_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/ppa.launchpad.net_webupd8team_java_ubuntu_dists_vivid_main_binary-amd64_Packages
                  MD5: 413372eec960dbbb3af5783097c677ea
 Description Language: en
                 File: /var/lib/apt/lists/ppa.launchpad.net_webupd8team_java_ubuntu_dists_vivid_main_i18n_Translation-en
                  MD5: 413372eec960dbbb3af5783097c677ea


Reverse Depends: 
  oracle-java8-unlimited-jce-policy,oracle-java8-installer 8u60+8u60arm-1~webupd8~1
  oracle-java8-set-default,oracle-java8-installer
Dependencies: 
8u60+8u60arm-1~webupd8~1 - java-common (2 0.24) locales (0 (null)) wget (0 (null)) binutils (0 (null)) debconf (18 0.5) debconf-2.0 (0 (null)) binfmt-support (0 (null)) visualvm (0 (null)) ttf-baekmuk (16 (null)) ttf-unfonts (16 (null)) ttf-unfonts-core (0 (null)) ttf-kochi-gothic (16 (null)) ttf-sazanami-gothic (0 (null)) ttf-kochi-mincho (16 (null)) ttf-sazanami-mincho (0 (null)) ttf-arphic-uming (0 (null)) firefox (16 (null)) firefox-2 (16 (null)) iceweasel (16 (null)) mozilla-firefox (16 (null)) iceape-browser (16 (null)) mozilla-browser (16 (null)) epiphany-gecko (16 (null)) epiphany-webkit (16 (null)) epiphany-browser (16 (null)) galeon (16 (null)) midbrowser (16 (null)) moblin-web-browser (16 (null)) xulrunner (16 (null)) xulrunner-1.9 (16 (null)) konqueror (16 (null)) chromium-browser (16 (null)) midori (16 (null)) google-chrome (0 (null)) gsfonts-x11 (0 (null)) j2se-common (0 (null)) j2se-common:i386 (0 (null)) icedtea-6-plugin (0 (null)) icedtea-6-plugin:i386 (0 (null)) icedtea-7-plugin (0 (null)) icedtea-7-plugin:i386 (0 (null)) openjdk-6-jre (0 (null)) openjdk-6-jre:i386 (0 (null)) openjdk-6-jre-headless (0 (null)) openjdk-6-jre-headless:i386 (0 (null)) openjdk-7-jdk (0 (null)) openjdk-7-jdk:i386 (0 (null)) openjdk-7-jre (0 (null)) openjdk-7-jre:i386 (0 (null)) openjdk-7-jre-headless (0 (null)) openjdk-7-jre-headless:i386 (0 (null)) oracle-java7-bin (0 (null)) oracle-java7-bin:i386 (0 (null)) oracle-java7-fonts (0 (null)) oracle-java7-fonts:i386 (0 (null)) oracle-java7-jdk (0 (null)) oracle-java7-jdk:i386 (0 (null)) oracle-java7-jre (0 (null)) oracle-java7-jre:i386 (0 (null)) oracle-java7-plugin (0 (null)) oracle-java7-plugin:i386 (0 (null)) oracle-java8-bin (0 (null)) oracle-java8-bin:i386 (0 (null)) oracle-java8-fonts (0 (null)) oracle-java8-fonts:i386 (0 (null)) oracle-java8-jdk (0 (null)) oracle-java8-jdk:i386 (0 (null)) oracle-java8-jre (0 (null)) oracle-java8-jre:i386 (0 (null)) oracle-java8-plugin (0 (null)) oracle-java8-plugin:i386 (0 (null)) oracle-jdk7-installer (0 (null)) oracle-jdk7-installer:i386 (0 (null)) oracle-jdk8-installer (0 (null)) oracle-jdk8-installer:i386 (0 (null)) 
Provides: 
8u60+8u60arm-1~webupd8~1 - oracle-java8-plugin oracle-java8-jre oracle-java8-jdk oracle-java8-fonts oracle-java8-bin oracle-java7-plugin oracle-java7-jre oracle-java7-jdk oracle-java7-fonts oracle-java7-bin openjdk-7-jre-headless openjdk-7-jre openjdk-7-jdk openjdk-6-jre-headless openjdk-6-jre java8-sdk java8-runtime-headless java8-runtime java8-jdk java7-sdk java7-runtime-headless java7-runtime java7-jdk java6-sdk java6-runtime-headless java6-runtime java6-jdk java5-sdk java5-runtime-headless java5-runtime java5-jdk java2-sdk java2-runtime-headless java2-runtime java2-jdk java-virtual-machine java-sdk java-runtime-headless java-runtime java-jdk java-compiler icedtea-7-plugin icedtea-6-plugin default-jre-headless default-jre 
Reverse Provides: 

I would prefer to leave the correct version of Java 8 in place, if possible.

Tags : java apt dpkg


Related Questions


Trying to remove faulty installation of Jenkins

Updated January 01, 2018 19:01 PM