linux's fdisk shows no partitions on old Windows hard drive

by Joshua Detwiler   Last Updated May 23, 2020 01:01 AM

I pulled an 80 GB WD hard drive out of my father's old (90's) IBM desktop computer. The only special thing about it is that it was once cloned from a smaller HDD as an upgrade to the 80 GB one (meaning nothing fancy like disk encryption should be expected).

I've been trying to do data recovery of the computers sitting in our basement (quarantine life), and this one is giving me trouble, not just because we lost some of the hardware to make that particular desktop boot. When I run fdisk /dev/sda from my (Arch) Linux setup, I'm seeing this:

Disk /dev/sda: 74.54 GiB, 80026361856 bytes, 156301488 sectors
Disk model:                 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0d179feb

It doesn't print out anything else indicating that it has partitions at all. I found the partprobe tool:

/dev/sda: msdos partitions

I also found the testdisk tool, but playing around with it, it didn't find partitions either (at least when I was selecting the Intel option). I tried Western Digital's analysis tool over in Windows too, but even their "extended test" gave the disk a pass.

Any help on getting this disk mounted please?

Tags : hard-drive mount


Related Questions




Portable HD not mounting

Updated September 09, 2019 14:01 PM