BitLocker automatic unlocking stopped working after updating grub from Linux

by Youda008   Last Updated September 21, 2018 16:01 PM

I bought a new laptop from Dell with Windows 10 Pro. It had a BitLocker encryption enabled by default, but it was suspended. I activated the protection and saved the recovery key.

Then i installed Ubuntu 18.04 and edited the grub entry to make Windows default. Since then automatic unlocking stopped working and booting to Windows would ask me to enter recovery key every time.

I tried the following advices:

  • suspend the BitLocker and activate it again
  • delete TPM protector and generate a new one
  • check if UEFI, SecureBoot and TPM 2.0 are enabled in BIOS

But none of that worked, it still asked me for recovery key.

I also wanted to try to completely disable BitLocker and decrypt the drive and then encrypt it again, but when re-enabling it i got this error:

enter image description here

So UEFI boot mode is enabled, SecureBoot is enabled, TPM 2.0 is there and enabled, the disk has GPT (and not MBR), but i still can't use BitLocker with automatic unlocking. Why??

Isn't it possible to use BitLocker and custom bootloader (such as grub) at the same time?



Related Questions





Encryption on High Availability solution

Updated December 01, 2017 02:01 AM

Encrypt (disk level) on Database Server MS SQL 2008

Updated December 05, 2017 17:01 PM