USB flash drive became Basic after installing BCD

by DD3R   Last Updated May 04, 2018 17:01 PM

TL;DR: Used "Install BCD" option and USB drive became "Basic" instead of "Removable".

I have a 64gb Sandisk flash drive, which was about 80% full. I wanted to install windows from it but didn't want to format it and lose data, so I googled if such a thing was possible, and came about an article saying to copy the .iso content onto flash drive and then use EasyBCD feature "Install BCD" to make it bootable.

easybcd

enter image description here

I did this and clicked Yes in the dialog, but when booting from usb it gave an error. I decided to move the files to pc and then use Media Creation Tool to prepare the USB, but to my surprise it couldn't see the drive. I saw that it had changed from being "Removable" type to being "Basic",

enter image description here

so the windows doesn't see it as a flash drive anymore. I can read/write to it without a problem.

I reformatted, deleted partition and recreated it multiple times. I tried lexar bootit but I don't think it worked.



Answers 1


"Removable" is a feature of the USB firmware (a bit in the Inquiry command), which should not disappear.

Did you already try erasing the first few sectors of the disk entirely (with a shredder program or directly with a disk hex editor)?

Ro-ee
Ro-ee
May 04, 2018 16:32 PM

Related Questions


Ubuntu: filesystem could not be mounted

Updated May 01, 2017 07:01 AM

Should i use ReFS instead of NTFS?

Updated July 11, 2017 02:01 AM

Windows 8.1 Pro won't boot, Status: 0xc000000e

Updated April 01, 2015 04:00 AM