MicroSD card not recognized anymore by Android phone

by user1283   Last Updated January 13, 2018 16:01 PM

Recently, I purchased a 32Gb Kingston MicroSD card for my Alcatel Onetouch Pixi running Android 5.1 with all the latest available updates.

When I first inserted the card, everything worked as expected and the phone detected the card. The only odd thing was that, on starup, the phone would display "Optimizing apps" and spend a long time going through 100 or so apps, and this occured at every reboot. Nevertheless, I had access to the storage, so I tried moving a couple apps to the MicroSD. This seemed to work but I eventually got some errors while trying to move apps, even when trying to move them back to internal storage. I had to reinstall a couple of apps, but everything else seemed to work fine.

A bit later, I noticed that the "optimizing apps" screen didn't appear anymore, so I checked and the SD card was not detected anymore. There was no difference between having the SD card in the phone or not. However, my computer could detect the card just fine. Other android devices also detect it normally. I have tried another MicroSD card and got the same result.

I tried cleaning the card gently, reformating it, and resetting my phone, but nothing worked. The MicroSD card should be compatible with the phone according to the infos I found online, which would be logical since it worked at first.

Is it possible to make the card functional again?

Tags : android sd-card


Related Questions


Big file keeps disappearing from SD card

Updated May 20, 2017 21:01 PM

Error whilst initializing SD card on Linux

Updated November 06, 2016 08:00 AM