kali 2.0 Sub-process /usr/bin/dpkg returned an error code (1)

by Anomaly   Last Updated March 11, 2017 21:01 PM

after attempting to install dependencies for steam, I am encountering errors with dpkg. Namely Sub-process /usr/bin/dpkg returned an error code (1). I am unable to install or purge packages. I am fairly new to the linux scene so please bear with me. If further information is required please let me know.

these are the commands ran from a tutorial on valves steam community page

       [+] apt-get install gdebi
       [+] dpkg --add-architecture i386
       [+] apt-get update
       [+] gdebi install steam*
       [+] apt-get install libgl1-mesa-dri:i386
       [+] apt-get install libGL.so.1
       [+] apt-get install libgl1-mesa-glx:i386
       [+] apt-get install '^libc6.*'

after attempting to install steam with gdebi i get

root@kali:~/Downloads# gdebi steam_latest.deb Reading package lists... Done Building dependency tree
Reading state information... Done Reading state information... Done This package is uninstallable Failed to satisfy all dependencies (broken cache)

so I attempt to install steam via apt-get and get this error

`Reading package lists... Done

Building dependency tree
Reading state information... Done You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: gcc-6-multilib : Depends: libc6-dev-i386 (>= 2.11) but it is not going to be installed libc6-dev-x32 : Depends: libc6-dev-i386 (= 2.24-9) but it is not going to be installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).`

Then I attempt to run apt --fix-broken install and I get...

apt --fix-broken install

Reading package lists... Done Building dependency tree
Reading state information... Done Correcting dependencies... Done The following packages were automatically installed and are no longer required: libgsoap10 liblircclient0 libmysqlclient18 libvncserver1 Use 'apt autoremove' to remove them. The following additional packages will be installed: libc6-dev-i386 The following NEW packages will be installed: libc6-dev-i386 0 upgraded, 1 newly installed, 0 to remove and 443 not upgraded. 3 not fully installed or removed. Need to get 0 B/1,652 kB of archives. After this operation, 9,166 kB of additional disk space will be used. Do you want to continue? [Y/n] y (Reading database ... 455344 files and directories currently installed.) Preparing to unpack .../libc6-dev-i386_2.24-9_amd64.deb ... Unpacking libc6-dev-i386 (2.24-9) ... dpkg: error processing archive /var/cache/apt/archives/libc6-dev-i386_2.24-9_amd64.deb (--unpack): trying to overwrite '/usr/include/bits', which is also in package libc6-dev-amd64:i386 2.24-9 Errors were encountered while processing: /var/cache/apt/archives/libc6-dev-i386_2.24-9_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) root@kali:~/Downloads#

any help would be greatly appreciated. I am currently unable to remove or install new packages.



Related Questions


How do I find out which package owns a file?

Updated August 30, 2015 00:00 AM

why apt-get cannot install any application?

Updated May 18, 2015 23:00 PM

/usr/bin/dpkg was accidentally deleted

Updated November 25, 2015 14:00 PM


Problems installing “sudo” under Debian 6

Updated June 22, 2018 16:01 PM