ubuntu: A lot of problems after abort an upgrade

by David Page   Last Updated March 26, 2016 08:00 AM

After I interrupt an upgrade, a lot of depending problems and broken packages appears. Here are my code,

sudo apt-get install -f
[sudo] password for user: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 137 not upgraded.
4 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
dpkg: error processing package libc6:amd64 (--configure):
 package libc6:amd64 2.21-0ubuntu4.1 cannot be configured because libc6:i386 is at a different version (2.21-0ubuntu4)
dpkg: dependency problems prevent configuration of libc-dev-bin:
 libc-dev-bin depends on libc6 (>> 2.21); however:
  Package libc6:amd64 is not configured yet.
 libc-dev-bin depends on libc6 (<< 2.22); however:
  Package libc6:amd64 is not configured yet.

dpkg: error processing package libc-dev-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc6-dev:amd64:
 libc6-dev:amd64 depends on libc6 (= 2.21-0ubuntu4.1); however:
  Package libc6:amd64 is not configured yet.
 libc6-dev:amd64 depends on libc-dev-bin (= 2.21-0ubuntu4.1); however:
  Package libc-dev-bin is not configured yet.

dpkg: error processing package libc6-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc6-dbg:amd64:
 libc6-dbg:amd64 depends on libc6 (= 2.21-0ubuntu4.1); however:
  Package libc6:amd64 is not configured yet.

dpkg: error processing package libc6-dbg:amd64 (--configure):
 No apport report written because the error message indicates its a followup error from a previous failure.
                           No apport report written because the error message indicates its a followup error from a previous failure.
                                                     No apport report written because MaxReports is reached already
                                   dependency problems - leaving unconfigured
Errors were encountered while processing:
 libc6:amd64
 libc-dev-bin
 libc6-dev:amd64
 libc6-dbg:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

There is something else may be useful.

sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of libc6-dbg:amd64:
 libc6-dbg:amd64 depends on libc6 (= 2.21-0ubuntu4.1); however:
  Package libc6:amd64 is not configured yet.

dpkg: error processing package libc6-dbg:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing package libc6:i386 (--configure):
 package libc6:i386 2.21-0ubuntu4 cannot be configured because libc6:amd64 is at a different version (2.21-0ubuntu4.1)
Errors were encountered while processing:
 libc6-dbg:amd64
 libc6:i386

I found this code,but seems no use

sudo apt-get -f dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  fonts-stix libappindicator1 libindicator7 libqt5x11extras5
  linux-headers-4.2.0-34 linux-headers-4.2.0-34-generic
  linux-image-4.2.0-34-generic linux-image-extra-4.2.0-34-generic
The following packages will be upgraded:
  bind9-host ca-certificates chromium-browser chromium-browser-l10n
  chromium-codecs-ffmpeg-extra cpio dnsutils eog firefox-locale-en
  firefox-locale-zh-hans flashplugin-installer fonts-opensymbol
  gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0
  gir1.2-javascriptcoregtk-3.0 gir1.2-webkit-3.0 git git-man glib-networking
  glib-networking-common glib-networking-services gstreamer1.0-alsa
  gstreamer1.0-libav gstreamer1.0-plugins-base gstreamer1.0-plugins-base-apps
  gstreamer1.0-plugins-good gstreamer1.0-pulseaudio gstreamer1.0-tools
  gstreamer1.0-x ifupdown libbind9-90 libdns-export100 libdns100
  libgail-common libgail18 libgcrypt20 libglib2.0-0 libglib2.0-bin
  libglib2.0-data libgraphite2-3 libgstreamer-plugins-base1.0-0
  libgstreamer-plugins-good1.0-0 libgstreamer1.0-0 libgtk2.0-0 libgtk2.0-bin
  libgtk2.0-common libhogweed4 libirs-export91 libisc-export95 libisc95
  libisccc90 libisccfg-export90 libisccfg90 libjasper1
  libjavascriptcoregtk-3.0-0 liblwres90 libnettle6 libnm-glib-vpn1 libnm-glib4
  libnm-util2 libnm0 libnss3 libnss3-nssdb libnuma1 libpam-modules
  libpam-modules-bin libpam-runtime libpam-systemd libpam0g libperl5.20
  libpurple-bin libpurple0 libreoffice-avmedia-backend-gstreamer
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-gnome libreoffice-gtk libreoffice-help-en-gb
  libreoffice-help-en-us libreoffice-help-zh-cn libreoffice-impress
  libreoffice-l10n-en-gb libreoffice-l10n-en-za libreoffice-l10n-zh-cn
  libreoffice-math libreoffice-ogltrans libreoffice-pdfimport
  libreoffice-style-galaxy libreoffice-style-human libreoffice-writer
  libsmbclient libssh-4 libssh-gcrypt-4 libssl1.0.0 libsystemd0 libtiff5
  libudev1 libwbclient0 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common
  linux-generic linux-headers-generic linux-image-generic multiarch-support
  network-manager openssl perl perl-base perl-modules python-samba
  python3-distupgrade python3-uno samba-common samba-common-bin samba-libs
  simple-scan systemd systemd-sysv thunderbird thunderbird-gnome-support
  thunderbird-locale-en thunderbird-locale-en-gb thunderbird-locale-en-us
  thunderbird-locale-zh-cn thunderbird-locale-zh-hans tzdata
  ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk udev uno-libs3
  update-notifier update-notifier-common ure zeal
137 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
4 not fully installed or removed.
Need to get 0 B/313 MB of archives.
After this operation, 318 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Extracting templates from packages: 100%
Preconfiguring packages ...
dpkg: error processing package libc6:amd64 (--configure):
 package libc6:amd64 2.21-0ubuntu4.1 cannot be configured because libc6:i386 is at a different version (2.21-0ubuntu4)
Errors were encountered while processing:
 libc6:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

Help guys,Please!Do I need reinstall dpkg?

Tags : ubuntu dpkg


Answers 2


First!! backup everything you can!

I have had this in the past and lost the install completely.

Then try removing the trouble package:

 sudo apt-get remove --purge libc6

If that is successful, retry:

 sudo apt-get -f dist-upgrade
Zogg
Zogg
March 26, 2016 13:29 PM

It might help to just install all packages from the cache:

sudo dpkg -i /var/cache/apt/archives/*deb

Credits: Question on askubuntu.com

Michael Kremser
Michael Kremser
June 02, 2016 06:01 AM

Related Questions


Errors were encountered while processing liblua

Updated September 21, 2016 09:21 AM

dpkg: dependency problems prevent configuration

Updated October 24, 2017 09:01 AM

Ubuntu Build Package From Source

Updated November 08, 2017 18:01 PM