How to program STM32L011

by A.Z   Last Updated October 10, 2018 15:25 PM

I tried to program specific STM ultra-low power series (STM32L011D4-tssop14). JLink programmer doesn't support this type of STM32 MCUs. so I tried to program this MCU by STLINK-V2 (SW mode). to do this I am doing the following works:

1- connect all wire which needed for this task (GND-VCC-SWDIO-SWCLK)

2- select "option for target..." in Keil 3- going to debug tab and select "ST-link debugger"

4- going to setting => as I know in "SW Device" section I should see the device information but I have an error " NO target Connected ".

that's weird for me when I connect RST pin of MCU to ground "SW Device" section showed device information. in this way, if I push F8 (Load in Keil) error appears "Core is held in reset"

it's reasonable when I force MCU to reset ( connect RST pin to GND) the program process shouldn't work ( "Core is held in reset" ) but if I don't do that programmer cant connect to the micro ("NO target Connected")

I don't know how should I Program this MCU...

Tags : stm32 low-power


Related Questions


Power consumption of Nucleo L432KC board

Updated April 18, 2018 15:25 PM


STM32L152 AND RTC

Updated February 17, 2017 15:25 PM

STM32f0 Low power mode

Updated September 01, 2016 08:10 AM