Image uploader messes up copy/paste function

by Catija   Last Updated August 03, 2015 17:10 PM

Clicking outside the image upload entry box to close it kills paste function.

System info: FF 39.0 & Chrome Version 43.0.2357.134 (64-bit) on Mac OSX

Explanation:

Occasionally when I'm using the image uploader to link to images on the web, I will be unable to paste the URL into the entry field or into the general text entry area.

The easiest way I've found to repro this is:

  1. Go to a question/answer entry field.
  2. Click on the uploader button.
  3. Click outside the area of the uploader window (closes the window).
  4. Try to use the paste shortcut in the answer entry area (doesn't work).
  5. Click on the uploader button.
  6. Click on the "You can also provide a link from the web." text to reveal the input box.
  7. Try to use the paste shortcut (doesn't work).
  8. Cry with frustration.
  9. Click on "cancel".
  10. Click on the "You can also provide a link from the web." text to reveal the input box again (still doesn't work).
  11. Cry some more.

It seems the current "fix" is to use the x in the upper right corner to close the dialogue box and the paste function returns but I swear (in my frustrated tear-fogged brain) that there have been times this did not "fix" it but I can't repro that now.

Also, the system is clearly trying to paste... the edit menu flashes the way it usually does when you paste something, it's just that the content of the paste never appears... or it's in some other universe.



Answers 1


This should be fixed in the next build (at time of writing, current is 2015.8.3.3627 - so something above that).

Marc Gravell
Marc Gravell
August 03, 2015 14:56 PM

Related Questions


Long image pasted into upload pushes footer up:

Updated April 16, 2015 20:10 PM

Uploading an image to chat clears existing reply

Updated May 16, 2015 21:10 PM