Xperia XZ Premium Dual recognizes Micro SIM cut to fit Nano tray, but not regular Nano SIM cards

by Alison E.E.   Last Updated February 20, 2019 06:11 AM

Ok, so I've got one headache inducing mind-boggler for y'all today. My phone (Xperia XZ Premium Dual, model number G8142, codename Maple, architecture Yoshino), has a rather odd issue when it comes to SIM cards.

The phone was network unlocked from the factory (which I believe is standard for this device, as you can't purchase it from any carrier). I was using AT&T. When I got the phone I had to cut my old Micro SIM card down with a SIM card cutter to fit its Nano tray. This SIM card worked fine from day one.

Recently I switched to Cricket, and in so doing I received a proper Nano SIM card. The card activated fine, but when I put it in my phone and rebooted it claimed there was "No SIM card inserted". I tried popping my AT&T card back in (the Micro cut to Nano spec), and it registered just fine.

I took my phone and both SIM cards down to the Cricket store, where we covered the basics and verified it wasn't a problem with the SIM card itself. I showed the clerk how the Micro-cut-Nano card would register, but the Nano wouldn't. She took her SIM out of her phone (a Cricket, Nano card), put it in mine, rebooted the phone, and it still read "No SIM card inserted".

After about fifteen minutes of confusion the manager came over, and we ran him through the situation, at which point he took his SIM out of his phone and put it into mine (an AT&T Nano card). Once again "No SIM card inserted". When I showed him that the Micro-cut-Nano card would register just fine, he noted that it was slightly thicker than the Nano cards.

In this vain I tried putting a small piece of cardstock paper under the Nano card in the tray. When I popped it in and rebooted it yet still read "No SIM card inserted". I'm at a complete loss.

The Micro-cut-Nano was a bit older, and was thus one of the thicker kind. My only inkling of an idea at this point is that maybe the pressure on the pins in SIM slot 1 caused them to flatten, making regular, thin Nano cards unable to contact. However if that was the case it should have registered when I added the cardstock.

It is a dual-SIM model, but the firmware I'm running right now doesn't support the second slot. I'm going to try downgrading to 8.1 (which had full support for both slots), to see if I can get any of the cards to register in slot 2. If so I will report back about which (Micro-cut-Nano/Cricket Nano/Backup AT&T Nano). While I would like to keep using Android 9, I still hope it will be as simple as downgrading and using SIM slot 2, because I would really like to avoid replacing this phone if at all possible.

If anyone else has experienced anything even remotely similar, or has any insight as to why this might be happening, please respond. Thanks.

Related Questions

Remove option for dual SIM in Sony Xperia C3 Dual

Updated January 12, 2017 08:04 AM

Kingroot how to uninstall

Updated February 20, 2017 17:11 PM

Can't connect to mobile network on Sony Xperia Z Ultra

Updated January 21, 2019 09:11 AM

Unroot Sony Xperia C3

Updated February 25, 2017 07:11 AM