MOTO E 1st Gen From Dalvik to ART : com.android.systemui stop and loop

by Kaldui   Last Updated March 13, 2017 17:11 PM

May I first apologize for my english : non-native speaker, some erratic grammar might happen.

Si un francophone passe ici, ce sera bien plus facile pour moi ;)

I'm NOT skilled in android fix, so be patient and please forgive if i ask you more precision to understand what you say ! Some previous questions were on the same problem, but i did not succeed on performing the solution, or [doesn't dare other] for i did not understood it2

I own a Motorola E, 1st Gen, since feb.2015.

  • Legal warranty void six weeks ago...
  • No root, no boot, no custom rom.
  • Kitkat 4.4 (or maybe 4.4.2, can't remember)

In the last weeks, a trouble appeared : i could neither listen or speak to my interlocutor, but by pluging in a wire headset or putting the phone on speaker (the one you shan't but still use while driving). The normal "phone pressed against the ear" did not worked anymore.

The first times, a simple reboot was all it needed to go back to normal.

Since a few days, reboot have no effect.

After an extend search on the internet, i found a solution for the Moto G (2nd gen) that appeared to work perfectly.

Going from Dalvik to ART, which i did friday (march 10th).

  • 1st reboot, upgrading 150 apps => Several error messages stated that XXX app has stopped. Then "com.android.systemui" has stop, and i cannot validate the prompt : once I click "OK", it comes back before i could even read the next error message. I can't do anything with the phone. ==> Reboot by long hold on POWER
  • 2nd reboot, upgrading 39 apps => Several messages again, com.android.systemui again ==> Reboot by long hold on POWER
  • 3rd reboot, the same
  • 4th reboot, upgrading 29 apps
  • 5th reboot, the same
  • 6th reboot, the same
  • 7th reboot, upgrading 28 apps.
  • xxth reboot, the same ...

Today, After a day's rest and no manipulation, count on upgrading application dropped to 27. By repetivly pressing "ok" and 'report" when avalaible, i somehow managed to get as far as parameters menu. Can't scoll in the microscopic time given between two prompt. However, -> The phone seems to receive calls (it ringed about an hour ago) but not to show the screen (caller ID, accepting the call, etc.) -> Afterward, the led flashed again.

The android buttons (back, home, active application list) doesn't show up.

And here i'm stuck !

What i tried :

  • A coffee. Did nothing to the phone, but improved my optimism
  • Shut it down, let it rest, power it
  • Fully charge it
  • Make it reboot by a long hold on power button while it was "upgrading 28 apps".
  • Pluging it to the computer, to see if it did anything (it didn't)
  • Making loud assumption on the engineer's mother honour and weight.
  • Go to recovery mode, and let it boot (if i understand well, it's just a normal boot for long inactivity)
  • Go to recovery mode, and wipe cache partition
  • Tried to do this : Moto E is not switching on after changing runtime to ART => I made it up to the 5th step ; but 6th don't work "Not recognized as a command or program" I tried the shell on E:\Programmes\AndroidSDK and E:\AndroidSDK\platform-tools. Neither works.

What should i do now ?

Thanks a lot,

Kaldui.



Related Questions




moto g2 bootloops

Updated April 17, 2016 08:04 AM

Moto G 2nd Gen - looping on optimizing apps

Updated December 18, 2017 02:11 AM