Strange Error - Please help understand this

by coderatlarge   Last Updated September 10, 2018 06:09 AM

I am trying to write a direct query in Magento and it is working fine in my local but in the test environment it is giving the following error:

Fatal error: Uncaught exception 'Exception' with message 'Warning: simplexml_load_string(): Entity: line 36: parser error : expected '>' in /var/www/html/lib/Varien/Simplexml/Config.php on line 510' in /var/www/html/app/code/core/Mage/Core/functions.php:245
Stack trace:
#0 [internal function]: mageCoreErrorHandler(2, 'simplexml_load_...', '/var/www/html/l...', 510, Array)
#1 /var/www/html/lib/Varien/Simplexml/Config.php(510): simplexml_load_string('<?xml version="...', 'Mage_Core_Model...')
#2 /var/www/html/lib/Varien/Simplexml/Config.php(498): Varien_Simplexml_Config->loadString('<?xml version="...', 'Mage_Core_Model...')
#3 /var/www/html/app/code/core/Mage/Core/Model/Config.php(277): Varien_Simplexml_Config->loadFile('/var/www/html/a...')
#4 /var/www/html/app/code/core/Mage/Core/Model/App.php(380): Mage_Core_Model_Config->loadBase()
#5 /var/www/html/app/code/core/Mage/Core/Model/App.php(268): Mage_Core_Model_App->_initBaseConfig()
#6 /var/www/html/app/Mage.php(616): Mage_Core_Model_App->init('', 'store', Array)
#7 / in /var/www/html/app/code/core/Mage/Core/functions.php on line 245

I have not touched Magento core files and I am new to Magento.



Answers 3


Your sql does not create issue this issue.Uncaught exception 'Exception' with message 'Warning: simplexml_load_string() issue is created for xml.

There are some issue in your layout files or config.xml,adminhtml.xml etc. You need to fix that.

Amit Bera
Amit Bera
February 13, 2016 06:49 AM

The &gt; means >

So you are missing a closing > in some xml configuration on line 36 if I get the message right.

Did you change some configuration files lately? You should start there. If not, you could add some temporary debug code in https://github.com/bragento/magento-core/blob/1.9/lib/Varien/Simplexml/Config.php#L495 to get the filename of the broken xml file

David Verholen
David Verholen
February 13, 2016 07:21 AM

  1. Please disable All third party extension, and then check the issue
  2. If issue is resolved please enable third party extension one by one and check the issue.
  3. If disabling third party extension not help please use the new setup files for this
Purushotam Sharma
Purushotam Sharma
February 13, 2016 07:44 AM

Related Questions


How to get all System Configration label

Updated June 19, 2017 14:09 PM

Miscellaneous HTML not showing

Updated May 22, 2017 11:09 AM

Magento 2 - Allow frontend run in frame

Updated December 06, 2017 00:09 AM